RIPng

RIPng fungerar på samma sätt som RIP för v4.
RIPng bärs av IPv6 och används för att utbyta IPv6-prefix enbart.

R1:

ipv6 unicast-routing
!
interface Loopback0
 ipv6 address 2001:db8:1:1::1/128
 ipv6 rip cisco enable
!
interface Serial0/0
 encapsulation ppp
 ipv6 address 2001:db8:0:12::1/64
 ipv6 rip cisco enable
!
ipv6 router rip cisco
!

R2:

ipv6 unicast-routing
!
interface Serial0/0
 encapsulation ppp
 ipv6 address 2001:db8:0:12::2/64
 ipv6 rip cisco enable
 clockrate 2000000
!
ipv6 router rip cisco
!