BGP för IPv6

BGP är multiprotokoll så här har vi bara adderat en adressfamilj till. Förutom detta har BGP skrivits om “underifrån” då BGP numera kan bäras av både IPv4 ELLER IPv6 eller t.o.m. i kombination till olika peers.
BGP kan därmed bl.a. bära IPv4- och IPv6-prefix mm.

R1:

ipv6 unicast-routing
!
interface Loopback0
 ipv6 address 2001:db8:4:4::4/128
!
interface FastEthernet0/1
 ipv6 address 2001:db8:0:24::4/64
!
interface Serial0/2
 ipv6 address 2001:db8:0:34::4/64
 clockrate 2000000
!
router bgp 65004
 bgp router-id 4.4.4.4
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2001:db8:0:24::2 remote-as 65002
 !
 address-family ipv6
 neighbor 2001:db8:0:24::2 activate
 network 2001:db8:0:34::/64
 network 2001:db8:4:4::4/128
 no synchronization
 exit-address-family

R2:

ipv6 unicast-routing
!
interface Loopback0
 ipv6 address 2001:db8:2:2::2/128
!
interface Ethernet0/1
 ipv6 address 2001:db8:0:24::2/64
!
router bgp 65002
 bgp router-id 2.2.2.2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2001:db8:0:24::4 remote-as 65004
 !
 address-family ipv6
 neighbor 2001:db8:0:24::4 activate
 network 2001:db8:2:2::/128
 no synchronization
 redistribute connected
 exit-address-family
!